いつのまにかWordPressのincludeのやり方が変わってた

Published:2013.01.16Last updated:2016.11.11

お久しぶりですこんにちは。
長らく放置していたブログですが今年こそちゃんと更新しようと思いまして、リニューアルみたいなことをやりました。

WordPressも3.2から3.5になりまして、タグの推奨非推奨とかもおさらいしておこうと思ったら3.0から、

< ?php include TEMPLATEPATH.'/shared/php/social.php'; ?>

みたいなインクルードの書き方が非推奨になったのだとか。
じゃあどうしたらいいの、というのが、

こちら。
デフォルトのテーマなんかでもloop.phpを呼び出すのに使ってたりした筈なのですが、深い階層にあるファイルをどうしたらいいのかとか拡張子はどうなるのとか一時間ほど悩んだ末、

< ?php get_template_part('shared/php/social'); ?>

このような書き方で無事動作しました。
管理しやすさ重視でかなり細かくインクルードしてるのでてんやわんやでした。
実は間違っていたりもっといい方法があったりしたら是非教えて下さい。

ではでは。

最新の記事

お知らせ